Main Site Documentation

Unable to communicate with device


#1

Just got domino with LCD shield…

Debugged with sample once…then tried the following code:



using System;

using Microsoft.SPOT;

using System.Threading;



using GHIElectronics.NETMF.FEZ;



namespace MFConsoleApplication3

{

public class Program

{

public static void Main()

{

FEZ_Shields.KeypadLCD.Initialize();

FEZ_Shields.KeypadLCD.TurnBacklightOn();

FEZ_Shields.KeypadLCD.Keys lKeyPress = FEZ_Shields.KeypadLCD.Keys.None;

int i = 0;

while (true)

{

FEZ_Shields.KeypadLCD.CursorHome();

FEZ_Shields.KeypadLCD.Print(“Count " + i++);

lKeyPress = FEZ_Shields.KeypadLCD.GetKey();

if (lKeyPress == FEZ_Shields.KeypadLCD.Keys.None)

continue;



FEZ_Shields.KeypadLCD.SetCursor(1, 2);

FEZ_Shields.KeypadLCD.Print(” ");

switch (lKeyPress)

{

case FEZ_Shields.KeypadLCD.Keys.Up:

FEZ_Shields.KeypadLCD.Print("Up ");

break;

case FEZ_Shields.KeypadLCD.Keys.Down:

FEZ_Shields.KeypadLCD.Print("Down ");

break;

case FEZ_Shields.KeypadLCD.Keys.Left:

FEZ_Shields.KeypadLCD.Print("Left ");

break;

case FEZ_Shields.KeypadLCD.Keys.Right:

FEZ_Shields.KeypadLCD.Print("Right “);

break;

case FEZ_Shields.KeypadLCD.Keys.Select:

FEZ_Shields.KeypadLCD.Print(“Select”);

break;

case FEZ_Shields.KeypadLCD.Keys.None:

FEZ_Shields.KeypadLCD.Print(” ");

break;

}

}

Thread.Sleep(100);

}

}

}



Now get unable to communicate with device…

Corresponds to my ‘How do you search this forum’ post…

Can’t believe I’m the first to hit this but this forum doesn’t have a search???


#2

Well, I used a different USB port and got it to ping…

Reloaded the firmware using TeraTerm…

Still Error 1 Unable to communicate with device - USB:USBizi from VS8…



Still pings…builds fine…preparing to deploy to device,unable to communicate…created a whole new project…same errors…


#3

Now my FEZ mini has same errors using an existing project that did work…

It prints debugs with mfdeploy connection…won’t debug in VS8


#4

Attempted to restart computer…BLUE DEATH SCREEN…something about usb debug driver…



Got rebooted…now all is working fine…



All this is on Vista Ultimate 64bit…



Some day when this forum is searchable others with same problems will find this ‘finding’ without going through hours of wasted trial time…


#5

The forum is still under work. it will have search feature in future.



About the error, with FEZ or any USB device, whenever you see things that do not make sense then a restart will probably fix the error.