Main Site Documentation

4.3" Cape on BeagleBone Black Wireless


#1

Hi! :slight_smile:
We would like to use a 4.3" Display Cape on BBB Wireless in a remote monitoring application (transmitting some video via WiFi and displaying it on another BBB Wireless w/ Display Cape).
What we are finding with the latest Debian (8.6) image however is that everything works “fine”, but extremely (unusably) slowly - “top” indicates that XOrg is using >90% CPU, and the XOrg log indicates some issues with “(EE) [mi] EQ overflowing.”.
(“dtb=am335x-boneblack-emmc-overlay.dtb” has already been uncommented in uEnv.txt).

We are not yet Linux experts at this stage - any ideas / pointers on how we might fix this would be appreciated? :smiley:

Thank You
Dane


#2

Someone here may know the answer but ay I suggest the Beagle bone forums. They have a lot of Linux and beaglebone experts on there.


#3

Hi Gus

Thanks for the fast reply! :slight_smile:

Apologies I could not reply for a while due to forum rules.

I’ve already tried beagleboard.org forums, no luck there ;-).

Seems like this issue will need some serious expertise to resolve - like getting hold of the guys who actually wrote the drivers :-D.

Thanks anyways!
Dane


#4

I have a 4.3" cape and am not experiencing this same issue, though I have heavily customized the OS, so it’s not and apples-to-apples comparison. A search for this error message on the web shows a lot of mentions of it as a bug in Ubuntu and X.

Is your system fully updated? Do : apt-get upgrade and apt-get update
If it is fully updated, then you may be experiencing an X bug which will require rolling your X server forward or back, but that’s a non-trivial operation, so I would certainly read through all of the mentions of that error message on the web - there are quite a few.


#5

@ ddp
In Debian 8.6 none of the overlays have been modified for BBB Wireless. Although some may work satisfactorily, uncommenting dtb=am335x-boneblack-emmc-overlay.dtb will cause problems with BBBW wireless. I am currently using https://rcn-ee.net/rootfs/bb.org/testing/2017-02-12/lxqt-4gb/bone-debian-8.7-lxqt-4gb-armhf-2017-02-12-4gb.img.xz
I have overcome my wireless problems using “uboot overlays”. See thread in this GHI Linux Forum above.
http://www.rescuerobot.org/drupal/?q=content/beaglebone-black-wireless