Main Site Documentation

TinyCLR Failed connecting UC5550


#1

I’m newly using UCM Dev Board with UC5550.
The new TinyCLR Preview 3 cannot list my UC5550 while Win10 Device Manager shows the USB device UC5550. Please see the attached picture.
I also tried setting the UC5550 into DFU mode ( press SYS A and RESET buttons) and plugged my PC’s USB cable to UART A port on UCM Dev Board. Going back to TinyCLR and I found the new virtual serial port can be listed in the Combo box of Port and I selected it. When I clicked the Connect button, the Rx led of UART A was flashing continuously. However, TinyCLR still cannot connect to the UC5550.


#2

Have you tried to update the firmware using TinyCLR config tool?


#3

i took the image of Tinyclr Config in the screenshot as meaning that was what was desired, but Config app couldn’t see it :wink:


#4

go ahead with the state that you see UC5550 under Device Manager, right click your mouse, uninstall UC5550 driver. If there is any box to check when right click to uninstall, check that box. Then hit reset button on the board.


#5

I have the same hardware and often the same problem.
The 5550 shows in Device Manager but cannot connect.

II found that if I do a rapid double click (or more) of the Reset button I then get a connection.

This also happens trying to debug in VS 2017 and after a RAPID double click VS will continue. Sometimes VS closes and then restarts.

Hope it helps…


#6

Gus,
Having updating the BootLoader V2.0.5 of UC5550 with DfuSeDemo, I am trying to download the firmware now. However, TinyCLR cannot connect with UC5550 on the UCM Dev Board. Suppose UC5550 should have been connected with TinyCLR via the USB port. Is it right?

I have tried both method recommended by Dat_Tran and willgeorge, but in vain.

Could you suggest any solution?


#7

willgeorge,

Thank you for your advice. I tried your suggestion but my effort in vain.
TinyCLR still fails connecting my UC5550 on UCM Dev Board via USB port.


#8

There is Boot D button that helps to switch from usb to serial port debug. Connect the cable to Serial Uart A on the board, hold that button and hit reset. From TinyCLR Config, select new Com Port, click connect and try to ping.

Let me know what you get first, also, try on a different computer if you have another one.

Also make sure exist application is erased before updating new firmware. This is not needed but just give it a try.


#9

What are the versions of your vs extension, nugget libraries, config tool?

http://docs.ghielectronics.com/software/tinyclr/downloads.html


#10

Followed along your advices.
When pressed the Connect button on TinyCLR Config, both Rx and Tx LEDs of UART A on UCM Dev Board are flashing continuously for a while. Eventually TinyCLR Config cannot receive any response and its status is “Connection Failed”. It appears that the latest TinyCLR Config is defective. I also tried all Preview version of TinyCLR Config but the results are same irresponsive.

my UC5550 is brand new and received in the last week from your factory.


#11

It shouldn’t be the case but, can you please look at on SDRAM and tell me, is it:
AS4C16M16SA or AS4C8M16SA?

Thanks