Main Site Documentation

TinyCLR.Devices.Display.1.0.0-preview3


#1

I have updated a working application to 1.0.0-preview3.

Using a UCM Dev Board Rev E with a UC5550 with WiFi
Using a UD700 Rev A display
GHIElectronics.TinyCLR.Devices.Display.1.0.0-preview3

The Display no longer works. Remains dark.
Display worked when using 1.0.0-preview2

Any suggestions?


#2

There are 2 things updated on graphic driver.

  1. The backlight pin is set by user manually. Meaning you have to pull this pin to high.
  2. You have to call controller.Enable() after Set Configuration.

#3

controller.Enable() Is used.

Now off to find that backlight pin…

I am not able to find the pin reference to the backlight pin.

Could you please provide. I have checked your Pin Assignments reference.

Thanks for the quick reply!


#4

Looking at the display schematic, the backlight pin is right next to 5v http://files.ghielectronics.com/downloads/Schematics/Systems/UD435%20Rev%20A%20Schematic.pdf

I do not have a board handy but take a look at the dev board please and see what pin that is.


#5

For quickly

UC5550 on Dev:
const int BACKLIGHT = 3 * 16 + 7; // PD7

FEZ Cobra II / G120E Dev:
const int BACKLIGHT = 2 * 32 + 21; // P2_21

G400D using UCM Dev board
const int BACKLIGHT = 3 * 32 + 14; // PD14 - UCM

These connect to GPIO A on UCM
GPIO B for interrupt, if I remember correctly.


#6

Thanks for the Info!

Got it working using:

private static GpioPin backlight_GPIOA;

//LCD Backlight - High = ON
backlight_GPIOA = GpioController.GetDefault().OpenPin(UC5550.GpioPin.PD7);
backlight_GPIOA.SetDriveMode(GpioPinDriveMode.Output);
backlight_GPIOA.Write(GpioPinValue.High);