Main Site Documentation

Cannot find any entrypoint


Hi Dat,

Sorry for my late reaction.
I followed the steps to build the test firmware with the above link as John suggested. I did not change any DEFAULT() to NO_INIT() yet. Do you still need my help? Otherwise I can try later this week.


That is enough for now, thank for your help.


New SDK was released yesterday, try it to see if you issue is gone or not. This has file system as you wanted.
If you have any spi devices that connect to spi2 bus, make sure its chip select is not low during starts up time.


Thank you Dat. I will try to install it tomorrow and will let you know if it solved my problem.


I never got around to trying it with the test firmware but it looks like preview 3 has fixed the problem


Preview 3 solved my problem as well. I now can deploy another project to the controller board as well when my first project is still loaded on the board (before I had to use TinyCLR config to erase it first). However I noticed something else. I made a small program to let 3 leds blink alternately with a pause of 100ms. This works well when debugging (I use G120 module) and direct after deploying. However after a reset of the board, it seems the leds blink alternately about 5 times slower. When I deploy it again or run the debugger, they blink at normal speed.


I might have spoken too soon… I can now deploy and run code on my G120E Dev board but the four micro switches on the right hand side have stopped working. I’m wondering if this has something to do with the NO_INIT changes you made in P3 (i’m assuming that’s what you did to fix it)


Buttons always need pull up or down activated. Usually it is a pull up. Did you set your input with pull up?


Can you share your test code?


Sure, see below:

using System.Threading;
using GHIElectronics.TinyCLR.Devices.Gpio;

class Program
    private static void Main()
        var led1 = GpioController.GetDefault().OpenPin(
        var led2 = GpioController.GetDefault().OpenPin(
        var led3 = GpioController.GetDefault().OpenPin(

        while (true)


Is this issue happened all board you have or just on the special board?


Thanks, I saw the issue blinking led slower without debugging.


Hello Dat,
Just to be sure, I tested with Fez Cobra III en Fez Panda III as well. They have the same problem.


Yes, thank for sharing, we are working on it.


Can you provide us a simple code that we can reproduce the issue with 5x slower? I can reproduce the issue but just a bit slower, not really 5x.



Hello Dat,

The code I sent 3 days ago (with 3 Leds) resulted in a lot slower blinking after deployment.
I am not sure that it is exactly 5 times slower (it is just an estimate), but it is considerably slower than in debug mode. I tested with FEZ cobra III and FEZ panda III with the built in leds. The same happened although the difference was not as big. My purpose is to use the G120 module on a special board for pressure regulating. Therefore I need a system that reacts as quick as possible. Although I realize it is not real time, it should be fast enough.


What you are seeing is not normal. TinyCLR is not real time but we are talking but milliseconds, not seconds.

In our test, we notice it running slightly slower but not 5 times, not even 2 times. Can you double check again please? We want to be 100% sure we have fixed this problem and to do so we need to reproduce the issue on our end to match what you are seeing.


Hi Gus, Thanks for your reaction. I will check again this weekend and let you know about the results.




Hi Gus,

I checked this weekend. You are right it is not 5 times slower, but I clocked some cycles with the G120 (special board based on G120 module) and the G80 (Fez Panda III), they both run about 2 times slower than in debug mode. In debug mode the Thread.Sleep time seems normal, but after a reset the Leds blink about 2 times slower.